Re: [PATCH v3 6/7] net: Rename skb_frag_t size to bv_len
From: Matthew Wilcox <willy@infradead.org>
Date: 2019-07-24 11:41:25
From: Matthew Wilcox <willy@infradead.org>
Date: 2019-07-24 11:41:25
On Wed, Jul 24, 2019 at 10:49:03AM +0000, David Laight wrote:
This is 'just plain stupid'. The 'bv_' prefix of the members of 'struct bvec' is there so that 'grep' (etc) can be used to find the uses of the members. In a 'struct skb_frag_struct' a sensible prefix might be 'sf_'. OTOH it might be sensible to use (or embed) a 'struct bvec' instead of 'skb_frag_struct'.
Maybe you should read patch 7/7. Or 0/7.