Re: [RFC 1/6] rcu: Add support for consolidated-RCU reader checking
From: Joel Fernandes <hidden>
Date: 2019-06-04 17:48:07
Also in:
linux-acpi, linux-pci, linux-pm, lkml, rcu
On Tue, Jun 04, 2019 at 06:53:58AM -0400, Steven Rostedt wrote:
On Mon, 3 Jun 2019 10:18:47 -0400 Joel Fernandes [off-list ref] wrote:quoted
On Mon, Jun 03, 2019 at 10:01:28AM +0200, Peter Zijlstra wrote:quoted
On Sat, Jun 01, 2019 at 06:27:33PM -0400, Joel Fernandes (Google) wrote:quoted
+#define list_for_each_entry_rcu(pos, head, member, cond...) \ + if (COUNT_VARGS(cond) != 0) { \ + __list_check_rcu_cond(0, ## cond); \ + } else { \ + __list_check_rcu(); \ + } \ + for (pos = list_entry_rcu((head)->next, typeof(*pos), member); \ + &pos->member != (head); \ pos = list_entry_rcu(pos->member.next, typeof(*pos), member)) /**@@ -621,7 +648,12 @@ static inline void hlist_add_behind_rcu(struct hlist_node *n, * the _rcu list-mutation primitives such as hlist_add_head_rcu() * as long as the traversal is guarded by rcu_read_lock(). */ +#define hlist_for_each_entry_rcu(pos, head, member, cond...) \ + if (COUNT_VARGS(cond) != 0) { \ + __list_check_rcu_cond(0, ## cond); \ + } else { \ + __list_check_rcu(); \ + } \ for (pos = hlist_entry_safe (rcu_dereference_raw(hlist_first_rcu(head)),\ typeof(*(pos)), member); \ pos; \This breaks code like: if (...) list_for_each_entry_rcu(...); as they are no longer a single statement. You'll have to frob it into the initializer part of the for statement.Thanks a lot for that. I fixed it as below (diff is on top of the patch): If not for that '##' , I could have abstracted the whole if/else expression into its own macro and called it from list_for_each_entry_rcu() to keep it more clean. ---8<-----------------------diff --git a/include/linux/rculist.h b/include/linux/rculist.h index b641fdd9f1a2..cc742d294bb0 100644 --- a/include/linux/rculist.h +++ b/include/linux/rculist.h@@ -371,12 +372,15 @@ static inline void list_splice_tail_init_rcu(struct list_head *list, * as long as the traversal is guarded by rcu_read_lock(). */ #define list_for_each_entry_rcu(pos, head, member, cond...) \ - if (COUNT_VARGS(cond) != 0) { \ - __list_check_rcu_cond(0, ## cond); \ - } else { \ - __list_check_rcu(); \ - } \ - for (pos = list_entry_rcu((head)->next, typeof(*pos), member); \ + for ( \ + ({ \ + if (COUNT_VARGS(cond) != 0) { \ + __list_check_rcu_cond(0, ## cond); \ + } else { \ + __list_check_rcu_nocond(); \ + } \ + }), \For easier to read I would do something like this: #define check_rcu_list(cond) \ ({ \ if (COUNT_VARGS(cond) != 0) \ __list_check_rcu_cond(0, ## cond); \ else \ __list_check_rcu_nocond(); \ }) #define list_for_each_entry_rcu(pos, head, member, cond...) \ for (check_rcu_list(cond), \
Yes, already doing it this way as I replied to Peter here: https://lore.kernel.org/patchwork/patch/1082846/#1278489 Thanks! - Joel