Re: [patch net-next RFC 00/12] devlink: introduce port flavours and common phys_port_name generation
flat view
From: David Ahern <hidden>
Date: 2018-03-22 15:34:16
On 3/22/18 4:55 AM, Jiri Pirko wrote:
From: Jiri Pirko <redacted> This patchset resolves 2 issues we have right now: 1) There are many netdevices / ports in the system, for port, pf, vf represenatation but the user has no way to see which is which 2) The ndo_get_phys_port_name is implemented in each driver separatelly, which may lead to inconsistent names between drivers.
Similar to ndo_get_phys_port_{name,id}, devlink requires drivers to opt
in with an implementation right, so you can't really force a solution to
the consistent naming.
This patchset introduces port flavours which should address the first problem. I'm testing this with Netronome nfp hardware. When the user has 2 physical ports, 1 pf, and 4 vfs, he should see something like this: # devlink port pci/0000:05:00.0/0: type eth netdev enp5s0np0 flavour physical number 0 pci/0000:05:00.0/268435456: type eth netdev eth0 flavour physical number 0 pci/0000:05:00.0/268435460: type eth netdev enp5s0np1 flavour physical number 1 pci/0000:05:00.0/536875008: type eth netdev eth2 flavour pf_rep number 536875008 pci/0000:05:00.0/536870912: type eth netdev eth1 flavour vf_rep number 0 pci/0000:05:00.0/536870976: type eth netdev eth3 flavour vf_rep number 1 pci/0000:05:00.0/536871040: type eth netdev eth4 flavour vf_rep number 2 pci/0000:05:00.0/536871104: type eth netdev eth5 flavour vf_rep number 3
How about 'kind' instead of flavo{u}r?