Re: [PATCH v6 bpf-next 07/11] tracepoint: introduce kernel_tracepoint_find_by_name
From: Daniel Borkmann <daniel@iogearbox.net>
Date: 2018-03-27 16:36:10
Also in:
linux-api
On 03/27/2018 05:53 PM, Alexei Starovoitov wrote:
On 3/27/18 7:42 AM, Steven Rostedt wrote:quoted
On Tue, 27 Mar 2018 10:18:24 -0400 (EDT) Mathieu Desnoyers [off-list ref] wrote:quoted
----- On Mar 27, 2018, at 10:07 AM, rostedt rostedt@goodmis.org wrote:quoted
On Mon, 26 Mar 2018 19:47:02 -0700 Alexei Starovoitov [off-list ref] wrote:quoted
From: Alexei Starovoitov <ast@kernel.org> introduce kernel_tracepoint_find_by_name() helper to let bpf core find tracepoint by name and later attach bpf probe to a tracepoint Signed-off-by: Alexei Starovoitov <ast@kernel.org>Reviewed-by: Steven Rostedt (VMware) <rostedt@goodmis.org>Steven showed preference for tracepoint_kernel_find_by_name() at some point (starting with a tracepoint_ prefix). I'm find with either of the names.Yeah, I do prefer tracepoint_kernel_find_by_name() to stay consistent with the other tracepoint functions. But we have "for_each_kernel_tracepoint()" and not "for_each_tracepoint_kernel()", thus we need to pick being consistent with one or the other. One answer is to use tracpoint_kernel_find_by_name() and rename the for_each to for_each_tracpoint_kernel().yep. that's exactly the reason I picked kernel_tracepoint_find_by_name() to match for_each_kernel_tracepoint() naming. I can certainly send a follow up patch to rename both to *tracepoint_kernel* and then you can nack it because it breaks lttng :) but let's do it in a separate thread. Daniel, do you mind adding { } as Steven requested while applying or you want me to resubmit the whole thing?
Yeah, I can fix it up while applying.