RE: [PATCH net-next 2/3] net: mvpp2: adjust gso stop wake thresholds
From: Yan Markman <hidden>
Date: 2018-02-27 17:48:56
Also in:
lkml
I will make this tomorrow. Thanks for attention! Best regards Yan Markman Tel. 05-44732819 -----Original Message----- From: Antoine Tenart [mailto:antoine.tenart@bootlin.com] Sent: Tuesday, February 27, 2018 7:14 PM To: David Miller <davem@davemloft.net> Cc: antoine.tenart@bootlin.com; Yan Markman <redacted>; mw@semihalf.com; Stefan Chulski <redacted>; thomas.petazzoni@free-electrons.com; gregory.clement@free-electrons.com; miquel.raynal@free-electrons.com; Nadav Haklai <redacted>; maxime.chevallier@bootlin.com; netdev@vger.kernel.org; linux-kernel@vger.kernel.org Subject: Re: [PATCH net-next 2/3] net: mvpp2: adjust gso stop wake thresholds Hi David, On Tue, Feb 27, 2018 at 11:13:06AM -0500, David Miller wrote:
From: Antoine Tenart <redacted>quoted
From: Yan Markman <redacted> -#define MVPP2_MAX_TSO_SEGS 300 +#define MVPP2_MAX_TSO_SEGS 100 #define MVPP2_MAX_SKB_DESCS (MVPP2_MAX_TSO_SEGS * 2 + MAX_SKB_FRAGS) /* Dfault number of RXQs in use */@@ -5810,7 +5810,7 @@ static int mvpp2_txq_init(struct mvpp2_port *port, txq_pcpu->tso_headers = NULL; txq_pcpu->stop_threshold = txq->size - MVPP2_MAX_SKB_DESCS; - txq_pcpu->wake_threshold = txq_pcpu->stop_threshold / 2; + txq_pcpu->wake_threshold = txq_pcpu->stop_threshold - 100;This number 100 is a magic constant. If it is related to MVPP2_MAX_TSO_SEGS, please use that define. Otherwise define a new one which is descriptive.
I agree. I'll ask Yan about it and update if possible. Thanks! Antoine -- Antoine Ténart, Bootlin (formerly Free Electrons) Embedded Linux and Kernel engineering https://bootlin.com