From: yuan linyu <redacted>
Date: Mon, 16 Oct 2017 20:11:13 +0800
From: yuan linyu <redacted>
add these two wrappers in skbuff.h which is better named
than previous and only used for skb.
Signed-off-by: yuan linyu <redacted>
Doing the skb_put() inside of the helper function makes code less
intuitive.
If someone is auditing code it's easier to see the skb_put() and
understand what is happening when it's at the call site rather than
buried in some helper.
Sorry, I don't see these changes as an improvement and will not apply
them.
Thank you.