Thread (21 messages) flat view 21 messages, 2 authors, 2017-09-29

Re: [PATCH net-next 0/8] net: dsa: change dsa_ptr for a dsa_port

From: Vivien Didelot <hidden>
Date: 2017-09-29 19:38:22
Also in: lkml

Hi Florian,

Florian Fainelli [off-list ref] writes:
On 09/29/2017 11:36 AM, Vivien Didelot wrote:
quoted
With DSA, a master net_device is physically wired to a dedicated CPU
switch port. For interaction with the DSA layer, the struct net_device
contains a dsa_ptr, which currently points to a dsa_switch_tree object.

This is only valid for a switch fabric with a single CPU port. In order
to support switch fabrics with multiple CPU ports, we first need to
change the type of dsa_ptr to what it really is: a dsa_port object.

This is what this patchset does. The first 4 patches cleans up portions
of DSA core to make the next patches more readable. These next patches
prepare the xmit and receive hot paths and finally change dsa_ptr.
This looks nice and clean, as mentioned in patch 5, there may be room
for organizing the structure a bit more efficiently such that everything
still fits within the first cacheline .
Thanks for this very constructive comment! I'll look into this.


Respinning in a few.

           Vivien
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help