Hi Hangbin,
On Thu, Jul 27, 2017 at 05:01:49PM +0800, Hangbin Liu wrote:
[...]
quoted hunk ↗ jump to hunk
diff --git a/lib/utils.c b/lib/utils.c
index e77bd30..0479e00 100644
--- a/lib/utils.c
+++ b/lib/utils.c
@@ -1215,5 +1215,6 @@ int get_real_family(int rtm_type, int rtm_family)
if (rtm_type != RTN_MULTICAST)
return rtm_family;
- return rtm_family == RTNL_FAMILY_IPMR ? AF_INET : AF_INET6;
+ return (rtm_family == RTNL_FAMILY_IPMR ||
+ rtm_family == AF_INET) ? AF_INET : AF_INET6;
}
I think this is not very readable. How about this instead:
- return rtm_family == RTNL_FAMILY_IPMR ? AF_INET : AF_INET6;
+ if (rtm_family == RTNL_FAMILY_IPMR)
+ return AF_INET;
+
+ return rtm_family;
Thanks, Phil