Thread (7 messages) flat view 7 messages, 2 authors, 2017-03-29

Re: [PATCH v2] netfilter: Clean up tests if NULL returned on failure

From: SIMRAN SINGHAL <hidden>
Date: 2017-03-29 09:16:04
Also in: lkml, lvs-devel, netfilter-devel

On Wed, Mar 29, 2017 at 2:19 PM, SIMRAN SINGHAL
[off-list ref] wrote:
On Wed, Mar 29, 2017 at 12:25 PM, Jan Engelhardt [off-list ref] wrote:
quoted
On Tuesday 2017-03-28 18:23, SIMRAN SINGHAL wrote:
quoted
On Tue, Mar 28, 2017 at 7:24 PM, Jan Engelhardt [off-list ref] wrote:
quoted
On Tuesday 2017-03-28 15:13, simran singhal wrote:
quoted
Some functions like kmalloc/kzalloc return NULL on failure. When NULL
represents failure, !x is commonly used.
@@ -910,7 +910,7 @@ ip_vs_new_dest(struct ip_vs_service *svc, struct ip_vs_dest_user_kern *udest,
      }

      dest = kzalloc(sizeof(struct ip_vs_dest), GFP_KERNEL);
-      if (dest == NULL)
+      if (!dest)
              return -ENOMEM;
This kind of transformation however is not cleanup anymore, it's really
bikeshedding and should be avoided. There are pro and cons for both
variants, and there is not really an overwhelming number of arguments
for either variant to justify the change.
Sorry, but I didn't get what you are trying to convey. And particularly pros and
cons of both variants.
The ==NULL/!=NULL part sort of ensures that the left side is a pointer, which
is lost when just using the variable and have it implicitly convert to bool.
Thanks for the explaination!!!!

But, according to me we should prefer != NULL over ==NULL according to
coding style.
Sorry their is typing mistake in above.

But, according to me we should prefer !var over ( var ==NULL ) according to the
coding style
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help