Thread (32 messages) flat view 32 messages, 3 authors, 2017-03-09

Re: [PATCH v4 net-next 12/13] mlx4: make validate_loopback() more generic

From: Tariq Toukan <hidden>
Date: 2017-03-09 14:15:07


On 08/03/2017 6:17 PM, Eric Dumazet wrote:
Testing a boolean in fast path is not worth duplicating
the code allocating packets, when GRO is on or off.

If this proves to be a problem, we might later use a jump label.

Next patch will remove this duplicated code and ease code review.

Signed-off-by: Eric Dumazet <edumazet@google.com>
---
 drivers/net/ethernet/mellanox/mlx4/en_rx.c       | 23 ++++++++++-------------
 drivers/net/ethernet/mellanox/mlx4/en_selftest.c |  6 ------
 2 files changed, 10 insertions(+), 19 deletions(-)
Acked-by: Tariq Toukan <redacted>

Thanks.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help