Re: [PATCH net-next] net/socket: use per af lockdep classes for sk queues
From: Eric Dumazet <hidden>
Date: 2017-03-08 17:11:26
On Wed, 2017-03-08 at 17:25 +0100, Paolo Abeni wrote:
quoted hunk ↗ jump to hunk
- no changes, tested with several different workload Suggested-by: Cong Wang <redacted> Signed-off-by: Paolo Abeni <pabeni@redhat.com> --- net/core/sock.c | 96 ++++++++++++++++++++++++++++++++++++++++++++++----------- 1 file changed, 78 insertions(+), 18 deletions(-)diff --git a/net/core/sock.c b/net/core/sock.c index f6fd79f..b7a3359 100644 --- a/net/core/sock.c +++ b/net/core/sock.c@@ -258,12 +258,66 @@ static const char *const af_family_clock_key_strings[AF_MAX+1] = { "clock-AF_NFC" , "clock-AF_VSOCK" , "clock-AF_KCM" , "clock-AF_QIPCRTR", "clock-AF_SMC" , "clock-AF_MAX" };
+static void sk_init_locks(struct sock *sk)
+{
+ skb_queue_head_init(&sk->sk_receive_queue);
+ skb_queue_head_init(&sk->sk_write_queue);
+ skb_queue_head_init(&sk->sk_error_queue);
+
+ rwlock_init(&sk->sk_callback_lock);
+ lockdep_set_class_and_name(&sk->sk_receive_queue.lock,...
+}
This is minor, but the function name does not really reflect what it does. Thanks !