Thread (2 messages) flat view 2 messages, 2 authors, 2016-10-31

Re: [PATCH net-next v2 1/1] driver: tun: Use new macro SOCK_IOC_TYPE instead of literal number 0x89

From: David Miller <davem@davemloft.net>
Date: 2016-10-31 14:57:40

From: fgao@ikuai8.com
Date: Thu, 27 Oct 2016 09:05:22 +0800
From: Gao Feng <redacted>

The current codes use _IOC_TYPE(cmd) == 0x89 to check if the cmd is one
socket ioctl command like SIOCGIFHWADDR. But the literal number 0x89 may
confuse readers. So create one macro SOCK_IOC_TYPE to enhance the readability.

Signed-off-by: Gao Feng <redacted>
Applied.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help