Thread (18 messages) 18 messages, 3 authors, 2016-09-22

Re: [patch net-next 3/6] mlxsw: spectrum_router: Use FIB notifications instead of switchdev calls

flat view

From: David Ahern <hidden>
Date: 2016-09-22 15:12:12

On 9/22/16 9:05 AM, Jiri Pirko wrote:
Thu, Sep 22, 2016 at 04:58:20PM CEST, dsa@cumulusnetworks.com wrote:
quoted
On 9/21/16 5:53 AM, Jiri Pirko wrote:
quoted
From: Jiri Pirko <redacted>

Until now, in order to offload a FIB entry to HW we use switchdev op.
However that has limits. Mainly in case we need to make the HW aware of
all route prefixes configured in kernel. HW needs to know those in order
to properly trap appropriate packets and pass the to kernel to do
the forwarding. Abort mechanism is now handled within the mlxsw driver.

Signed-off-by: Jiri Pirko <redacted>
---
 drivers/net/ethernet/mellanox/mlxsw/spectrum.h     |   9 +-
 .../net/ethernet/mellanox/mlxsw/spectrum_router.c  | 386 ++++++++++++---------
 .../ethernet/mellanox/mlxsw/spectrum_switchdev.c   |   9 -
 3 files changed, 216 insertions(+), 188 deletions(-)

Make the move to fib notifiers and the removal of switchdev code separate patches. It will make the fib notifier change easier to follow.
Since I'm changing one iface by another, I don't see how I can split it.
Make the previous API dead and remove it in a separate patch. 

The init/fini code changes -- just a code move, no logical changes? then make it a separate patch - or don't move it at all and just add prototypes.

Some important code blocks are hard to read through the diffs as they are now.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help