Thread (4 messages) flat view 4 messages, 4 authors, 2016-08-13

Re: [PATCH net] bpf: fix bpf_skb_in_cgroup helper naming

From: Martin KaFai Lau <hidden>
Date: 2016-08-13 06:14:32

On Fri, Aug 12, 2016 at 10:17:17PM +0200, Daniel Borkmann wrote:
While hashing out BPF's current_task_under_cgroup helper bits, it came
to discussion that the skb_in_cgroup helper name was suboptimally chosen.

Tejun says:

  So, I think in_cgroup should mean that the object is in that
  particular cgroup while under_cgroup in the subhierarchy of that
  cgroup. Let's rename the other subhierarchy test to under too. I
  think that'd be a lot less confusing going forward.

  [...]

  It's more intuitive and gives us the room to implement the real
  "in" test if ever necessary in the future.

Since this touches uapi bits, we need to change this as long as v4.8
is not yet officially released. Thus, change the helper enum and rename
related bits.
Thanks for working on this and be-lated

Acked-by: Martin KaFai Lau <redacted>
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help