Thread (4 messages) flat view 4 messages, 4 authors, 2016-08-10

Re: [PATCH net-next v11 5/6] openvswitch: add layer 3 flow/port support

From: Simon Horman <hidden>
Date: 2016-08-10 10:16:45

Possibly related (same subject, not in this thread)

On Mon, Aug 08, 2016 at 05:28:39PM +0200, Jiri Benc wrote:
On Mon, 8 Aug 2016 17:17:17 +0200, Simon Horman wrote:
quoted
+bool skb_mac_header_present(struct sk_buff *skb)
+{
+	return skb->dev->type == ARPHRD_ETHER ||
+		(skb->dev->type == ARPHRD_NONE &&
+		 skb->protocol == htons(ETH_P_TEB));
+}
+EXPORT_SYMBOL(skb_mac_header_present);
I'd suggest a different name, this looks like it has something to do
with skb->mac_header, which it doesn't. skb_eth_header_present, perhaps?
I struggled to come up with a reasonable name and I do like your
suggestion better than mine. I'll update the code as you suggest unless a
better name emerges.
_______________________________________________
dev mailing list
dev@openvswitch.org
http://openvswitch.org/mailman/listinfo/dev
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help