On Wed, Jan 06, 2016 at 10:32:16PM +0100, Daniel Borkmann wrote:
Move the details behind the cb[] access into a small helper to decouple
and make them generic for bpf_prog_run_save_cb()/bpf_prog_run_clear_cb()
that was introduced via commit ff936a04e5f2 ("bpf: fix cb access in socket
filter programs"). Also add a comment to better clarify what is done in
bpf_skb_cb().
Signed-off-by: Daniel Borkmann <daniel@iogearbox.net>
Thanks. Great catch.
Acked-by: Alexei Starovoitov <ast@kernel.org>