Re: [PATCH 07/15] i40iw: add hw and utils files
From: Christoph Hellwig <hidden>
Date: 2015-12-17 16:07:36
Also in:
linux-rdma
+#ifndef UNREFERENCED_PARAMETER
+#define UNREFERENCED_PARAMETER(_p) \
+{ \
+ (_p) = (_p); \
+}
+#endifNo need for this, just remove it.
+#define I40E_MASK(mask, shift) (mask << shift)
Please just opencode the shit, this macro is silly.
+#define i40iw_flush(a) readl((a)->hw_addr + I40E_GLGEN_STAT) + +#define wr32(a, reg, value) writel((value), (a)->hw_addr + (reg)) +#define rd32(a, reg) readl((a)->hw_addr + (reg))
Please urn these into inlines.
+
+#ifndef readq
+static inline u64 rd64(u8 * __iomem addr)
+{
+ return ((u64)readl(addr)) | (((u64)readl(addr + 4UL)) << 32);
+}
+#else
+#define rd64(a) readq((a))
+#endifPlease use the magic in <linux/io-64-nonatomic-lo-hi.h> instead.
+ +#define db_wr32(a, value) writel((value), (a))
Pleas remove this pointless wrapper.
+void SLEEP(u8 ms);
Please give this function a sensible name. -- To unsubscribe from this list: send the line "unsubscribe linux-rdma" in the body of a message to majordomo-u79uwXL29TY76Z2rM5mHXA@public.gmane.org More majordomo info at http://vger.kernel.org/majordomo-info.html