From: Taku Izumi <redacted>
Date: Thu, 20 Aug 2015 17:46:08 +0900
quoted hunk ↗ jump to hunk
+
+err_register:
+ fjes_hw_exit(&adapter->hw);
+err_hw_init:
+err_sw_init:
+ free_netdev(netdev);
+err_alloc_netdev:
+ return err;
Having multiple code labels in the same exact spot is suboptimal.
Instead, name the labels such that they describe the first cleanup
action they will perform, instead of the context in which they are
jumped to from.
So "err_hw_exit:", "err_free_netdev", and "err_out:" would be
appropriate.