On 21/08/15 16:16, David Daney wrote:
From: David Daney <redacted>
commit 18ee49ddb0d2 ("phylib: rename mii_bus::dev to mii_bus::parent")
changed the parent of PHY devices from the bus to the bus parent.
Then, commit 4dea547fef1b ("phylib: rework to prepare for OF
registration of PHYs") moved the code into phy_device.c
At this point, it is somewhat unclear why the change was seen as
necessary. But, when we look at the device model tree in
/sys/devices, it is clearly incorrect. The PHYs should be children of
their MDIO bus.
Change the PHY's parent device to be the MDIO bus device.
Cc: Lennert Buytenhek <redacted>
Cc: Grant Likely <redacted>
Signed-off-by: David Daney <redacted>
Acked-by: Florian Fainelli <f.fainelli@gmail.com>
--
Florian