From: Alexei Starovoitov <redacted>
Date: Tue, 4 Aug 2015 22:51:07 -0700
IFLA_VXLAN_FLOWBASED is useless without IFLA_VXLAN_COLLECT_METADATA,
so combine them into single IFLA_VXLAN_COLLECT_METADATA flag.
'flowbased' doesn't convey real meaning of the vxlan tunnel mode.
This mode can be used by routing, tc+bpf and ovs.
Only ovs is strictly flow based, so 'collect metadata' is a better
name for this tunnel mode.
Signed-off-by: Alexei Starovoitov <redacted>
---
it's not too late to kill uapi IFLA_VXLAN_FLOWBASED, since it
was introduced two weeks ago.
Alternatively we could rename both into vxlan_accept_metadata
or something else, but imo collect_metadata is ok.
Applied, thanks.