Thread (4 messages) 4 messages, 3 authors, 2015-07-06

RE: [PATCH net-next] hv_netvsc: Add support to set MTU reservation from guest side

flat view

From: Haiyang Zhang <haiyangz@microsoft.com>
Date: 2015-07-06 19:48:11
Also in: lkml

-----Original Message-----
From: David Miller [mailto:davem@davemloft.net]
Sent: Friday, July 3, 2015 12:17 PM
To: dan.carpenter@oracle.com
Cc: Haiyang Zhang; netdev@vger.kernel.org; olaf@aepfle.de;
jasowang@redhat.com; driverdev-devel@linuxdriverproject.org; linux-
kernel@vger.kernel.org
Subject: Re: [PATCH net-next] hv_netvsc: Add support to set MTU
reservation from guest side

From: Dan Carpenter <redacted>
Date: Fri, 3 Jul 2015 14:28:47 +0300
quoted
On Thu, Jul 02, 2015 at 01:17:35PM -0700, Haiyang Zhang wrote:
quoted
When packet encapsulation is in use, the MTU needs to be reduced for
headroom reservation.
The existing code takes the updated MTU value only from the host side.
But vSwitch extensions, such as Open vSwitch, require the flexibility
to change the MTU to different values from within a guest during the
lifecycle of a vNIC, when the encapsulation protocol is changed. The
patch supports this kind of MTU changes.

Signed-off-by: Haiyang Zhang <haiyangz@microsoft.com>
Reviewed-by: K. Y. Srinivasan <redacted>
---
 drivers/net/hyperv/netvsc_drv.c   |    3 +--
 drivers/net/hyperv/rndis_filter.c |    2 +-
 2 files changed, 2 insertions(+), 3 deletions(-)
diff --git a/drivers/net/hyperv/netvsc_drv.c
b/drivers/net/hyperv/netvsc_drv.c
quoted
quoted
index 358475e..68e7ece 100644
--- a/drivers/net/hyperv/netvsc_drv.c
+++ b/drivers/net/hyperv/netvsc_drv.c
@@ -743,8 +743,7 @@ static int netvsc_change_mtu(struct net_device
*ndev, int mtu)
quoted
quoted
 	if (nvdev->nvsp_version >= NVSP_PROTOCOL_VERSION_2)
 		limit = NETVSC_MTU - ETH_HLEN;

-	/* Hyper-V hosts don't support MTU < ETH_DATA_LEN (1500) */
-	if (mtu < ETH_DATA_LEN || mtu > limit)
+	if (mtu < 68 || mtu > limit)
How did you calculate 68?  Avoid magic numbers like this, make it a
define.
Agreed.
The number 68 is same as the common code in eth_change_mtu(). I think it
came from the protocol requirement:
https://en.wikipedia.org/wiki/Maximum_transmission_unit

Sure, I will put the number in a define, and resubmit the patch.

Thanks,
- Haiyang
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help