On Mon, Feb 23, 2015 at 11:48 PM, David Miller [off-list ref] wrote:
From: Shmulik Ladkani <redacted>
Date: Mon, 23 Feb 2015 20:56:33 +0200
quoted
May I suggest to unalias 'mark' out of the union?
Only in exchange for finding a way to remove completely another object
of the same size from sk_buff.
I refuse to let it grow any more, it's already way too big.
I agree that aliasing skb->priority with skb->dropcount and
skb->reserved_tailroom is
less than optimal.
I can suggest an alternative patch following Eric Dumazet's suggestion in which
skb->dropcount is removed and skb->cb[] is used instead for keeping dropcount.
That would require protocol family implementations to access skb->cb[]
via a common
accessor or use a common offset #define from the start of skb->cb[].
Eyal.