Thread (19 messages) flat view 19 messages, 5 authors, 2014-07-29

Re: [PATCH net-next] net: filter: rename 'struct sk_filter' to 'struct bpf_prog'

From: Daniel Borkmann <hidden>
Date: 2014-07-25 13:00:26
Also in: lkml, netfilter-devel

On 07/25/2014 01:54 PM, Pablo Neira Ayuso wrote:
On Fri, Jul 25, 2014 at 01:25:35PM +0200, Daniel Borkmann wrote:
quoted
[ also Cc'ing Willem, Pablo ]

On 07/25/2014 10:04 AM, Alexei Starovoitov wrote:
quoted
'sk_filter' name is used as 'struct sk_filter', function sk_filter() and
as variable 'sk_filter', which makes code hard to read.
Also it's easily confused with 'struct sock_filter'
Rename 'struct sk_filter' to 'struct bpf_prog' to clarify semantics and
align the name with generic BPF use model.
Agreed, as we went for kernel/bpf/, renaming makes absolutely sense.
My nft socket filtering changes are accomodated into struct sk_filter,
and will still be, so I still need some generic name there...
All the parts from filter.c which is BPF's core engine have been moved
into kernel/bpf/ to get it ready for tracing et al, since there is not
always a socket context anymore. The *whole* infrastructure around struct
sk_filter is [e]BPF and used in non-net related contexts as well, whereas
nft socket filtering is *only* for sockets. Due to the socket-only specific
use case why doesn't it make more sense to have a union in struct sock
around sk_filter (or however we name it) and only allow one of the two
being loaded on a socket?
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help