From: Benoit Taine <redacted>
Date: Fri, 18 Jul 2014 17:26:47 +0200
We should prefer `const struct pci_device_id` over
`DEFINE_PCI_DEVICE_TABLE` to meet kernel coding style guidelines.
This issue was reported by checkpatch.
A simplified version of the semantic patch that makes this change is as
follows (http://coccinelle.lip6.fr/):
// <smpl>
@@
identifier i;
declarer name DEFINE_PCI_DEVICE_TABLE;
initializer z;
@@
- DEFINE_PCI_DEVICE_TABLE(i)
+ const struct pci_device_id i[]
= z;
// </smpl>
I have 103 patches ready, and will only send a few for you to judge if
it is useful enough, and to prevent from spamming too much.
I'm fine with this wrt. the networking changes, but I don't think this should
be merged via my tree.