[PATCH 2/3 v2] ipv6: rename ADBG() to pr_xxx()

Subsystems: networking [general], networking [ipv4/ipv6], the rest

STALE4761d

4 messages, 3 authors, 2013-08-14 · open the first message on its own page

[PATCH 2/3 v2] ipv6: rename ADBG() to pr_xxx()

From: Ding Tianhong <hidden>
Date: 2013-08-13 08:06:49

According to Joe Perches opinions, the ADBG() was tedious and it is
better to remove the KERN_<LEVEL>s and use the pr_xxx() instead of ADBG().

Signed-off-by: Ding Tianhong <redacted>
Cc: Joe Perches <joe@perches.com>
---
 net/ipv6/addrconf.c | 29 +++++++++--------------------
 1 file changed, 9 insertions(+), 20 deletions(-)
diff --git a/net/ipv6/addrconf.c b/net/ipv6/addrconf.c
index 72911fd..2333fa7 100644
--- a/net/ipv6/addrconf.c
+++ b/net/ipv6/addrconf.c
@@ -95,15 +95,6 @@
 #include <linux/seq_file.h>
 #include <linux/export.h>
 
-/* Set to 3 to get tracing... */
-#define ACONF_DEBUG 2
-
-#if ACONF_DEBUG >= 3
-#define ADBG(x) printk x
-#else
-#define ADBG(x)
-#endif
-
 #define	INFINITY_LIFE_TIME	0xFFFFFFFF
 
 static inline u32 cstamp_delta(unsigned long cstamp)
@@ -369,9 +360,8 @@ static struct inet6_dev *ipv6_add_dev(struct net_device *dev)
 	dev_hold(dev);
 
 	if (snmp6_alloc_dev(ndev) < 0) {
-		ADBG((KERN_WARNING
-			"%s: cannot allocate memory for statistics; dev=%s.\n",
-			__func__, dev->name));
+		pr_warning("%s: cannot allocate memory for statistics; dev=%s.\n",
+			__func__, dev->name);
 		neigh_parms_release(&nd_tbl, ndev->nd_parms);
 		dev_put(dev);
 		kfree(ndev);
@@ -379,9 +369,8 @@ static struct inet6_dev *ipv6_add_dev(struct net_device *dev)
 	}
 
 	if (snmp6_register_dev(ndev) < 0) {
-		ADBG((KERN_WARNING
-			"%s: cannot create /proc/net/dev_snmp6/%s\n",
-			__func__, dev->name));
+		pr_warning("%s: cannot create /proc/net/dev_snmp6/%s\n",
+			__func__, dev->name);
 		neigh_parms_release(&nd_tbl, ndev->nd_parms);
 		ndev->dead = 1;
 		in6_dev_finish_destroy(ndev);
@@ -844,7 +833,7 @@ ipv6_add_addr(struct inet6_dev *idev, const struct in6_addr *addr,
 
 	/* Ignore adding duplicate addresses on an interface */
 	if (ipv6_chk_same_addr(dev_net(idev->dev), addr, idev->dev)) {
-		ADBG(("ipv6_add_addr: already assigned\n"));
+		pr_err("ipv6_add_addr: already assigned\n");
 		err = -EEXIST;
 		goto out;
 	}
@@ -852,7 +841,7 @@ ipv6_add_addr(struct inet6_dev *idev, const struct in6_addr *addr,
 	ifa = kzalloc(sizeof(struct inet6_ifaddr), GFP_ATOMIC);
 
 	if (ifa == NULL) {
-		ADBG(("ipv6_add_addr: malloc failed\n"));
+		pr_err("ipv6_add_addr: malloc failed\n");
 		err = -ENOBUFS;
 		goto out;
 	}
@@ -2069,7 +2058,7 @@ void addrconf_prefix_rcv(struct net_device *dev, u8 *opt, int len, bool sllao)
 	pinfo = (struct prefix_info *) opt;
 
 	if (len < sizeof(struct prefix_info)) {
-		ADBG(("addrconf: prefix option too short\n"));
+		pr_err("addrconf: prefix option too short\n");
 		return;
 	}
 
@@ -3649,8 +3638,8 @@ restart:
 	if (time_before(next_sched, jiffies + ADDRCONF_TIMER_FUZZ_MAX))
 		next_sched = jiffies + ADDRCONF_TIMER_FUZZ_MAX;
 
-	ADBG((KERN_DEBUG "now = %lu, schedule = %lu, rounded schedule = %lu => %lu\n",
-	      now, next, next_sec, next_sched));
+	pr_debug("now = %lu, schedule = %lu, rounded schedule = %lu => %lu\n",
+	      now, next, next_sec, next_sched);
 
 	addr_chk_timer.expires = next_sched;
 	add_timer(&addr_chk_timer);
-- 
1.8.2.1

Re: [PATCH 2/3 v2] ipv6: rename ADBG() to pr_xxx()

From: Hannes Frederic Sowa <hidden>
Date: 2013-08-13 11:37:20

On Tue, Aug 13, 2013 at 03:57:28PM +0800, Ding Tianhong wrote:
quoted hunk
According to Joe Perches opinions, the ADBG() was tedious and it is
better to remove the KERN_<LEVEL>s and use the pr_xxx() instead of ADBG().

Signed-off-by: Ding Tianhong <redacted>
Cc: Joe Perches <joe@perches.com>
---
 net/ipv6/addrconf.c | 29 +++++++++--------------------
 1 file changed, 9 insertions(+), 20 deletions(-)
diff --git a/net/ipv6/addrconf.c b/net/ipv6/addrconf.c
index 72911fd..2333fa7 100644
--- a/net/ipv6/addrconf.c
+++ b/net/ipv6/addrconf.c
@@ -95,15 +95,6 @@
 #include <linux/seq_file.h>
 #include <linux/export.h>
 
-/* Set to 3 to get tracing... */
-#define ACONF_DEBUG 2
-
-#if ACONF_DEBUG >= 3
-#define ADBG(x) printk x
Please either change this to pr_warning, pr_err.
quoted hunk
-#else
-#define ADBG(x)
-#endif
-
 #define	INFINITY_LIFE_TIME	0xFFFFFFFF
 
 static inline u32 cstamp_delta(unsigned long cstamp)
@@ -369,9 +360,8 @@ static struct inet6_dev *ipv6_add_dev(struct net_device *dev)
 	dev_hold(dev);
 
 	if (snmp6_alloc_dev(ndev) < 0) {
-		ADBG((KERN_WARNING
-			"%s: cannot allocate memory for statistics; dev=%s.\n",
-			__func__, dev->name));
+		pr_warning("%s: cannot allocate memory for statistics; dev=%s.\n",
+			__func__, dev->name);
Or these to pr_debug/pr_dbg (for use with dynamic_debug).

I don't think it gives an advantage to emit debug messages which were designed
solely for debugging purposes before.

I would actually favour the dynamic_debug method.

Greetings,

  Hannes

Re: [PATCH 2/3 v2] ipv6: rename ADBG() to pr_xxx()

From: Joe Perches <joe@perches.com>
Date: 2013-08-13 16:48:55

On Tue, 2013-08-13 at 15:57 +0800, Ding Tianhong wrote:
According to Joe Perches opinions, the ADBG() was tedious and it is
better to remove the KERN_<LEVEL>s and use the pr_xxx() instead of ADBG().
No, that's not really what I wrote.

I suggested it might be better to remove the KERN_<LEVELS>
from these ADBG uses and use pr_debug.

As is, you've changed logging messages which today
always compile away to nothing to now emit what I
think are pretty unnecessary messages.

Re: [PATCH 2/3 v2] ipv6: rename ADBG() to pr_xxx()

From: Ding Tianhong <hidden>
Date: 2013-08-14 01:44:18

On 2013/8/14 0:48, Joe Perches wrote:
On Tue, 2013-08-13 at 15:57 +0800, Ding Tianhong wrote:
quoted
According to Joe Perches opinions, the ADBG() was tedious and it is
better to remove the KERN_<LEVEL>s and use the pr_xxx() instead of ADBG().
No, that's not really what I wrote.

I suggested it might be better to remove the KERN_<LEVELS>
from these ADBG uses and use pr_debug.

As is, you've changed logging messages which today
always compile away to nothing to now emit what I
think are pretty unnecessary messages.
sorry for misunderstand your opinion, I will modify it and resend soon.:)

regards
Ding Tianhong
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help