From: Lorenzo Colitti <redacted>
Date: Wed, 29 May 2013 14:47:37 +0900
udp6_sock_seq_show and raw6_sock_seq_show are identical, except
the UDP version displays ports and the raw version displays the
protocol. Refactor most of the code in these two functions into
a new common ip6_dgram_sock_seq_show function, in preparation
for using it to display ICMPv6 sockets as well.
Also reduce the indentation in parts of include/net/transp_v6.h
to improve readability.
Compiles and displays reasonable results with CONFIG_IPV6={n,m,y}
Signed-off-by: Lorenzo Colitti <redacted>
Do not mix functional changes with unrelated whitespace and other cleanups.
Split this patch series up properly and resubmit this entire series.