Thread (3 messages) flat view 3 messages, 2 authors, 2012-08-16

Re: [PATCH v2] XFRM: remove redundant parameter "int dir" in struct xfrm_mgr.acquire

From: Fan Du <hidden>
Date: 2012-08-16 01:11:48


On 2012年08月16日 06:14, David Miller wrote:
From: Fan Du<redacted>
Date: Wed, 15 Aug 2012 10:13:47 +0800
quoted
Sematically speaking, xfrm_mgr.acquire is called when kernel intends to ask
user space IKE daemon to negotiate SAs with peers. IOW the direction will
*always* be XFRM_POLICY_OUT, so remove int dir for clarity.

Signed-off-by: Fan Du<redacted>
---
Changelog for V2:
	- Remove "int dir" in build_acquire parameter suggested by Steffen Klassert.
Applied, thanks.

Please use lowercase "xfrm: " for subsystem indications in your subject
lines, I fixed it up this time.

Thanks again.
Well understood, will do it next time :)
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
-- 

Love each day!
--fan
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help