Thread (2 messages) flat view 2 messages, 2 authors, 2012-05-10

Re: [PATCH 07/14] batman-adv: split neigh_new function into generic and batman iv specific parts

From: David Miller <hidden>
Date: 2012-05-10 16:07:28
Also in: batman

From: Sven Eckelmann <redacted>
Date: Thu, 10 May 2012 09:34:25 +0200
On Wednesday, May 09, 2012 08:41:11 PM David Miller wrote:
[...]
quoted
The namespace pollution of the batman-adv code needs to improve,
and I'm putting my foot down starting with this change.

If you have a static function which is therefore private to a
source file, name it whatever you want.

But once it gets exported out of that file, you have to give it
an appropriate name.  Probably with a "batman_adv_" prefix or
similar.
I aggree, but would like to like to have a shorter prefix batadv_. I know that 
you said "or similar" but there are still some developers that fear your 
response to a patch that only adds the prefix batadv_ instead of the longer 
version.
batadv_ is fine.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help