Thread (15 messages) flat view 15 messages, 3 authors, 2012-05-10

Re: [PATCH 07/14] batman-adv: split neigh_new function into generic and batman iv specific parts

From: David Miller <davem@davemloft.net>
Date: 2012-05-10 00:44:22
Also in: batman

From: Antonio Quartulli <redacted>
Date: Wed,  9 May 2012 13:12:49 +0200
From: Marek Lindner <redacted>

Signed-off-by: Marek Lindner <redacted>
Acked-by: Simon Wunderlich <redacted>
Signed-off-by: Antonio Quartulli <redacted>
The namespace pollution of the batman-adv code needs to improve,
and I'm putting my foot down starting with this change.

If you have a static function which is therefore private to a
source file, name it whatever you want.

But once it gets exported out of that file, you have to give it
an appropriate name.  Probably with a "batman_adv_" prefix or
similar.

Otherwise, for one thing, if this code is statically built into
the tree it can conflict with symbol names elsewhere and break
the build.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help