From: Bruce Allan <redacted>
Rename e1000e_setup_link() to e1000e_setup_link_generic() to signify
the
function is used for more than one MAC-family type. The 82571-family
has
a custom setup_link function which also calls the generic function.
The
ich8lan-family has a custom function which should just be called via
the
function pointer. The 80003es2lan-family just uses the generic
function.
Wouldn't it be better to add a suffix to the family-specific
functions instead of adding a lot of unnecessary churn?
David