Re: Re: WARNING: at kernel/softirq.c:159 _local_bh_enable_ip+0x35/0x71()
flat view
From: Peter Zijlstra <peterz@infradead.org>
Date: 2012-02-23 13:22:43
On Thu, 2012-02-23 at 12:53 +0100, Eric Dumazet wrote:
Hmm, I am not sure we still need local_bh_disable()/local_bh_enable() in kmap_skb_frag()/ kunmap_skb_frag() anymore after commit 3e4d3af501ccc (mm: stack based kmap_atomic() )
The only thing to consider is keeping the total stack size under control, this is somewhat non-trivial since its non-obvious what all nests. That said, you're probably right, and we do have a WARN in there (dependent on CONFIG_DEBUG_HIGHMEM) that yells if we exceed the available stack size. The more 'interesting' exercise is determining a better upper bound on the stack size and updating kmap_types.h accordingly.
quoted hunk ↗ jump to hunk
diff --git a/net/core/kmap_skb.h b/net/core/kmap_skb.h index 81e1ed7..06be5ee 100644 --- a/net/core/kmap_skb.h +++ b/net/core/kmap_skb.h@@ -2,18 +2,10 @@ static inline void *kmap_skb_frag(const skb_frag_t *frag) { -#ifdef CONFIG_HIGHMEM - BUG_ON(in_irq()); - - local_bh_disable(); -#endif return kmap_atomic(skb_frag_page(frag), KM_SKB_DATA_SOFTIRQ); } static inline void kunmap_skb_frag(void *vaddr) { kunmap_atomic(vaddr, KM_SKB_DATA_SOFTIRQ); -#ifdef CONFIG_HIGHMEM - local_bh_enable(); -#endif }
The nicer patch would of course be a patch that does: s/kunmap_skb_frag/kunmap_atomic/ s/kmap_skb_frag(\([^)]*\))/kmap_atomic(skb_frag_page(\1))/ There is no need to retain the KM_* argument and the 'helper' functions are quite pointless at that point.