[PATCH] net/mac80211/debugfs: Convert to kstrou8_from_user

Subsystems: mac80211, the rest

STALE5450d

3 messages, 2 authors, 2011-08-30 · open the first message on its own page

[PATCH] net/mac80211/debugfs: Convert to kstrou8_from_user

From: Peter Huewe <peterhuewe@gmx.de>
Date: 2011-06-07 20:36:30

This patch replaces the code for getting an number from a
userspace buffer by a simple call to kstrou8_from_user.
This makes it easier to read and less error prone.

Since the old buffer was only 10 bytes long and the value is masked by a
nibble-mask anyway, we don't need to use kstrtoul but rather kstrtou8.

Kernel Version: v3.0-rc2

Signed-off-by: Peter Huewe <peterhuewe@gmx.de>
---
 net/mac80211/debugfs.c |   14 +++-----------
 1 files changed, 3 insertions(+), 11 deletions(-)
diff --git a/net/mac80211/debugfs.c b/net/mac80211/debugfs.c
index 186e02f..267ed45 100644
--- a/net/mac80211/debugfs.c
+++ b/net/mac80211/debugfs.c
@@ -195,20 +195,12 @@ static ssize_t uapsd_queues_write(struct file *file,
 				  size_t count, loff_t *ppos)
 {
 	struct ieee80211_local *local = file->private_data;
-	unsigned long val;
-	char buf[10];
-	size_t len;
+	u8 val;
 	int ret;
 
-	len = min(count, sizeof(buf) - 1);
-	if (copy_from_user(buf, user_buf, len))
-		return -EFAULT;
-	buf[len] = '\0';
-
-	ret = strict_strtoul(buf, 0, &val);
-
+	ret = kstrtou8_from_user(user_buf, count, 0, &val);
 	if (ret)
-		return -EINVAL;
+		return ret;
 
 	if (val & ~IEEE80211_WMM_IE_STA_QOSINFO_AC_MASK)
 		return -ERANGE;
-- 
1.7.3.4

Re: [PATCH] net/mac80211/debugfs: Convert to kstrou8_from_user

From: Peter Hüwe <PeterHuewe@gmx.de>
Date: 2011-08-28 19:52:45

Am Dienstag 07 Juni 2011, 22:36:14 schrieb Peter Huewe:
This patch replaces the code for getting an number from a
userspace buffer by a simple call to kstrou8_from_user.
This makes it easier to read and less error prone.

Since the old buffer was only 10 bytes long and the value is masked by a
nibble-mask anyway, we don't need to use kstrtoul but rather kstrtou8.

Kernel Version: v3.0-rc2

Signed-off-by: Peter Huewe <peterhuewe@gmx.de>
Any updates on this one?
Still applies to the latest linus' tree

Thanks,
Peter

Re: [PATCH] net/mac80211/debugfs: Convert to kstrou8_from_user

From: John W. Linville <hidden>
Date: 2011-08-30 18:00:26

On Sun, Aug 28, 2011 at 09:52:31PM +0200, Peter Hüwe wrote:
Am Dienstag 07 Juni 2011, 22:36:14 schrieb Peter Huewe:
quoted
This patch replaces the code for getting an number from a
userspace buffer by a simple call to kstrou8_from_user.
This makes it easier to read and less error prone.

Since the old buffer was only 10 bytes long and the value is masked by a
nibble-mask anyway, we don't need to use kstrtoul but rather kstrtou8.

Kernel Version: v3.0-rc2

Signed-off-by: Peter Huewe <redacted>
Any updates on this one?
Still applies to the latest linus' tree
I merged it to wireless-next yesterday.

Thanks for the reminder!

John
-- 
John W. Linville		Someday the world will need a hero, and you
linville-2XuSBdqkA4R54TAoqtyWWQ@public.gmane.org			might be all we have.  Be ready.
--
To unsubscribe from this list: send the line "unsubscribe linux-wireless" in
the body of a message to majordomo-u79uwXL29TY76Z2rM5mHXA@public.gmane.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help