On Wed, 4 May 2011 23:51:19 +0300, "Michael S. Tsirkin" [off-list ref] wrote:
quoted hunk ↗ jump to hunk
Define a new feature bit for the host to
declare that it uses an avail_event index
(like Xen) instead of a feature bit
to enable/disable interrupts.
Signed-off-by: Michael S. Tsirkin <mst@redhat.com>
---
include/linux/virtio_ring.h | 11 ++++++++---
1 files changed, 8 insertions(+), 3 deletions(-)
diff --git a/include/linux/virtio_ring.h b/include/linux/virtio_ring.h
index f5c1b75..f791772 100644
--- a/include/linux/virtio_ring.h
+++ b/include/linux/virtio_ring.h
@@ -32,6 +32,9 @@
/* The Guest publishes the used index for which it expects an interrupt
* at the end of the avail ring. Host should ignore the avail->flags field. */
#define VIRTIO_RING_F_USED_EVENT_IDX 29
+/* The Host publishes the avail index for which it expects a kick
+ * at the end of the used ring. Guest should ignore the used->flags field. */
+#define VIRTIO_RING_F_AVAIL_EVENT_IDX 32
Are you really sure we want to separate the two? Seems a little simpler
to have one bit to mean "we're publishing our threshold". For someone
implementing this from scratch, it's a little simpler.
Or are there cases where the old style makes more sense?
Thanks,
Rusty.