Re: pull request: batman-adv 2011-05-08
From: David Miller <hidden>
Date: 2011-05-08 22:40:06
Also in:
batman
From: Sven Eckelmann <redacted> Date: Sun, 8 May 2011 17:24:36 +0200
Hi, I would like to propose following patches for net-next-2.6/2.6.40. They include minor cleanups of comments, a big rename patch s/hna/tt/, but also a remove some duplicated code. The spinlock which protected the list of possible interfaces for batman-adv was completely replaced by rtnl_lock because we want to be in sync with the rest of the network stack and the extra spinlock made everything more complex without giving any additional feature (and rtnl_lock was already used everywhere). Related to this patch is also a fix which should prevent a deadlock between the sysfs code and the event listener. Also the reference counting in find_router was fixed when an error was detected after the refcounter was already increased. The only feature is the support for multiple vlans in the bridge loop detection code. I will submit a patch to remove the atomic_dec_not_zero from main.h after Linus accepted the patch you already saw.
Pulled, thanks Sven.