Re: [PATCH 2/4] macvlan: cleanup rx statistics
From: Eric Dumazet <hidden>
Date: 2009-11-24 08:16:41
Also in:
bridge, lkml
Arnd Bergmann a écrit :
quoted hunk ↗ jump to hunk
We have very similar code for rx statistics in two places in the macvlan driver, with a third one being added in the next patch. Consolidate them into one function to improve overall readability of the driver. Signed-off-by: Arnd Bergmann <arnd@arndb.de> --- drivers/net/macvlan.c | 63 +++++++++++++++++++++++++----------------------- 1 files changed, 33 insertions(+), 30 deletions(-)diff --git a/drivers/net/macvlan.c b/drivers/net/macvlan.c index ae2b5c7..a0dea23 100644 --- a/drivers/net/macvlan.c +++ b/drivers/net/macvlan.c@@ -116,42 +116,53 @@ static int macvlan_addr_busy(const struct macvlan_port *port, return 0; } +static inline void macvlan_count_rx(const struct macvlan_dev *vlan, int length, + int success, int multicast)
success and multicast should be declared as bool
+{
+ struct macvlan_rx_stats *rx_stats;
+
+ rx_stats = per_cpu_ptr(vlan->rx_stats, smp_processor_id());
+ rx_stats->rx_packets += success != 0;
+ rx_stats->rx_bytes += success ? length : 0;
+ rx_stats->multicast += success && multicast;
+ rx_stats->rx_errors += !success;
+}
+
I find following more readable, it probably generates more branches,
but avoid dirtying rx_errors if it is in another cache line.
if (likely(success)) {
rx_stats->rx_packets++;
rx_stats->rx_bytes += length;
if (multicast)
rx_stats->multicast++;
} else {
rx_stats->rx_errors++;
}
- rx_stats = per_cpu_ptr(vlan->rx_stats, smp_processor_id());
skb = skb_share_check(skb, GFP_ATOMIC);
- if (skb == NULL) {
- rx_stats->rx_errors++;
- return NULL;
- }
-
- rx_stats->rx_bytes += skb->len + ETH_HLEN;
- rx_stats->rx_packets++;
+ macvlan_count_rx(vlan, skb->len + ETH_HLEN, likely(skb != NULL), 0);its not _likely_ that skb != NULL, its a fact :) -> macvlan_count_rx(vlan, skb->len + ETH_HLEN, true, false);