On Fri, 2008-07-25 at 18:29 +0900, KOSAKI Motohiro wrote:
quoted
Hi Peter,
quoted
__GFP_MEMALLOC will allow the allocation to disregard the watermarks,
much like PF_MEMALLOC.
It allows one to pass along the memalloc state in object related allocation
flags as opposed to task related flags, such as sk->sk_allocation.
Is this properly name?
page alloc is always "mem alloc".
you wrote comment as "Use emergency reserves" and
this flag works to turn on ALLOC_NO_WATERMARKS.
then, __GFP_NO_WATERMARK or __GFP_EMERGENCY are better?
We've been through this pick a better name thing several times :-/
Yes I agree, __GFP_MEMALLOC is a misnomer, however its consistent with
PF_MEMALLOC and __GFP_NOMEMALLOC - of which people know the semantics.
Creating a new name with similar semantics can only serve to confuse.
Ah, understand.
Thanks.
Agreed to __GFP_MEMALLOC.
So unless enough people think its worth renaming all of them, I think
we're better off with this name.