Re: [PATCH 1/4] [SCTP]: "list_for_each()" -> "list_for_each_entry()" where appropriate.
From: Vlad Yasevich <hidden>
Date: 2008-03-29 00:59:30
From: Vlad Yasevich <hidden>
Date: 2008-03-29 00:59:30
David Miller wrote:
From: Vlad Yasevich <redacted> Date: Fri, 28 Mar 2008 10:56:17 -0400quoted
From: Robert P. J. Day <redacted> Replacing (almost) all invocations of list_for_each() with list_for_each_entry() tightens up the code and allows for the deletion of numerous list iterator variables that are no longer necessary. Signed-off-by: Robert P. J. Day <redacted> Signed-off-by: Vlad Yasevich <redacted>This is not a "bug fix", it's a huge cleanup and thus not appropriate for 2.6.x Please rebuild this patch series without this patch included, you can submit it for 2.6.26
Sorry about that, you are right. Will do. -vlad