Re: [PATCH] NET: Add the helper kernel_sock_shutdown()
From: David Howells <dhowells@redhat.com> Date: 2007-11-09 01:45:16
Trond Myklebust [off-list ref] wrote:
Looking at the sock->op->shutdown() handlers, it looks as if all of them
take a SHUT_RD/SHUT_WR/SHUT_RDWR argument instead of the
RCV_SHUTDOWN/SEND_SHUTDOWN arguments.
Add a helper, and then define the SHUT_* enum to ensure that kernel users
of shutdown() don't get confused.