Thread (1 message) 1 message, 1 author, 2007-09-09

Re: [PATCH 03/16] net: Basic network namespace infrastructure.

From: Eric W. Biederman <hidden>
Date: 2007-09-09 10:18:22

Eric Dumazet [off-list ref] writes:
Nice work Eric !
Thanks.
"struct net" is not a very descriptive name imho, why dont stick "ns" or
"namespace" somewhere ?
My fingers rebelled, and struct net seems to be sufficiently descriptive.
However that is a cosmetic detail and if there is a general consensus
that renaming it to be struct netns or whatever would be a more
readable/maintainable name I can change it.
Do we really need yet another "struct kmem_cache *net_cachep;" ?
The object is so small that the standard caches should be OK (kzalloc())
The practical issue at this point in the cycle is visibility.  With a
kmem cache it is easy to spot ref counting leaks or other problems
if they happen.  Without it debugging is much more difficult.  While I
am touched with your faith in my ability to write perfect patches I
think it makes a lot of sense to keep the cache at least until
sometime after the network namespace code is merged and people
generally have confidence in the implementation.

Eric
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help