On 9/17/07, David Miller [off-list ref] wrote:
From: Denis Cheng <redacted>
Date: Sun, 2 Sep 2007 03:45:58 +0800
quoted
with the macro max provided by <linux/kernel.h>, so changed its name to a more proper one: limit
Signed-off-by: Denis Cheng <redacted>
Not strictly necessary because CPP knows to differentiate between
'max(' and plain 'max' when evaluating if a CPP macro should be
expanded or not.
I also know the GNU CPP is intelligent, but people are often not.
I just think the avoidance to use human ambiguous names could give
more readability.
Nonetheless, applied to net-2.6.24, thanks.
--
Denis Cheng