Kris Katterjohn [off-list ref] wrote:
Another patch for net/core/filter.c by me. I merged __load_pointer() into
load_pointer(). I don't see a point in having two seperate functions when
both functions are really small and load_pointer() calls __load_pointer().
Renamed the variable "k" to "offset" since that's what it is, and in
skb_header_pointer() it's "offset".
This patch is a diff from kernel 2.6.14
This code path is performance-critical so you should benchmark your
changes.
In this particular case, __load_pointer is the unlikely case and
therefore it wasn't inlined.
Cheers,
--
Visit Openswan at http://www.openswan.org/
Email: Herbert Xu ~{PmV>HI~} [off-list ref]
Home Page: http://gondor.apana.org.au/~herbert/
PGP Key: http://gondor.apana.org.au/~herbert/pubkey.txt