On Sat, Nov 08, 2003 at 08:44:06PM -0800, Randy.Dunlap wrote:
Here's an update for 2.6.0-test9. This update adds
dev_alloc_name_lock(), which takes and releases the rtnl lock
to call dev_alloc_name(), so that the caller doesn't have to do that.
More comments?
I don't like that name for the function. dev_alloc_name_lock() makes it
natural to think that there is a matching dev_alloc_name_unlock() function
which you should call afterwards. How about dev_alloc_name_locked() or
dev_alloc_name_with_lock() instead?
--
Regards,
Rask Ingemann Lambertsen