On (21/08/03 10:29), Hans Verkuil wrote:
quoted
+static void set_queue_coherency(struct vb2_queue *q, bool coherent_mem)
+{
+ q->coherent_mem = 1;
This I do not like: coherent memory is the default, and so I think it will
be more robust if this field is renamed to non_coherent_mem and so coherent
memory will be the default since this field will be cleared initially with
kzalloc.
Basically a similar argument that you used in patch 2/8.
I also think that it improves readability, since non-coherent is the
exceptional case, not the rule, and the field name corresponds with the
V4L2 memory flag name.
I noticed that in v1 of this series it was actually called non_coherent_mem,
and it was changed in v2, actually after some comments from me.
But I changed my mind on that, and I think it makes more sense to go back to
calling this non_coherent_mem.
Ok, done. Hans, is this your final decision? :)