On Mon, Feb 20, 2012 at 11:24 AM, Mark Brown
[off-list ref] wrote:
On Fri, Feb 10, 2012 at 03:40:36PM +0900, MyungJoo Ham wrote:
quoted
+ [EXTCON_AUDIO_IN] = "Audio-in",
+ [EXTCON_AUDIO_OUT] = "Audio-out",
Can I suggest making these more specific - how about
[EXTCON_LINE_IN] = "Line-in",
[EXTCON_LINE_OUT] = "Line-out",
[EXTCON_MIC_IN] = "Microphone",
[EXTCON_HEADPHONE_OUT] = "Headphone",
as a starting point? The distinction between line and the other two is
often pretty important from a UI/system interaction point of view.
Sure, this looks more generic. I'll add them along with SPDIF in/out.
quoted
+ /* TODO: remove before submit */
+ pr_info("[%s][%d]\n", buffer, enabled);
:)
Whoops...
--
MyungJoo Ham, Ph.D.
System S/W Lab, Software Center, Samsung Electronics