Thread (21 messages) 21 messages, 3 authors, 2021-12-10

Re: [PATCH v11 2/5] arm64: Rename unwinder functions

From: Madhavan T. Venkataraman <hidden>
Date: 2021-11-30 17:16:36
Also in: linux-arm-kernel, lkml


On 11/30/21 9:08 AM, Mark Rutland wrote:
On Tue, Nov 23, 2021 at 01:37:20PM -0600, madvenka@linux.microsoft.com wrote:
quoted
From: "Madhavan T. Venkataraman" <redacted>

Rename unwinder functions for consistency and better naming.

	- Rename start_backtrace() to unwind_start().
	- Rename unwind_frame() to unwind_next().
	- Rename walk_stackframe() to unwind().
Super trivial, but could we s/unwind_start/unwind_init/ ? That makes it
slightly clearer that it's not performing an unwind step.

Otherwise, this looks good to me.
Will do.
For the rename:

Acked-by: Mark Rutland <mark.rutland@arm.com>

It's be nice if we could also clean up 'struct stackframe' into 'struct
unwind_state', but that can be a follow-up, and this is fine as it is, modulo
the super trivial comment above.
I could do this rename as well in the next version if you want. Might as well
get all the renaming done in one shot.

Thanks,

Madhavan
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help