Thread (9 messages) flat view 9 messages, 2 authors, 1d ago

Re: [PATCH v3 1/3] powerpc/numa: Simplify find_primary_domain_index

From: Shrikanth Hegde <hidden>
Date: 2026-09-04 10:06:13
Also in: lkml


On 9/2/26 6:05 PM, Srikar Dronamraju wrote:
Initialize the return value once and use a single exit path in
find_primary_domain_index().

This is a small cleanup that keeps the existing behavior unchanged while
making the control flow easier to follow.
Reviewed-by: Shrikanth Hegde <redacted>
quoted hunk ↗ jump to hunk
Signed-off-by: Srikar Dronamraju <redacted>
---
Changelog from v1:
- Handle comments from Christophe Leroy

  arch/powerpc/mm/numa.c | 7 ++-----
  1 file changed, 2 insertions(+), 5 deletions(-)
diff --git a/arch/powerpc/mm/numa.c b/arch/powerpc/mm/numa.c
index f4cf3ae036de..c44a80d8fc11 100644
--- a/arch/powerpc/mm/numa.c
+++ b/arch/powerpc/mm/numa.c
@@ -432,7 +432,7 @@ static void __init initialize_form2_numa_distance_lookup_table(void)
  
  static int __init find_primary_domain_index(void)
  {
-	int index;
+	int index = -1;
  	struct device_node *root;
  
  	/*
@@ -502,12 +502,9 @@ static int __init find_primary_domain_index(void)
  		distance_ref_points_depth = MAX_DISTANCE_REF_POINTS;
  	}
  
-	of_node_put(root);
-	return index;
-
  err:
  	of_node_put(root);
-	return -1;
+	return index;
  }
  
  static void __init get_n_mem_cells(int *n_addr_cells, int *n_size_cells)
  
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help