Re: [PATCHv2 0/8] gpio: move ppc4xx driver to drivers/gpio and modernize
From: Madhavan Srinivasan <maddy@linux.ibm.com>
Date: 2026-08-11 04:53:47
Also in:
linux-gpio, lkml
On Mon, 03 Aug 2026 15:35:31 -0700, Rosen Penev wrote:
This series moves the ppc4xx GPIO driver from arch/powerpc to drivers/gpio, converts it to be a proper platform driver using generic MMIO helpers, drops architecture-specific accessors, and prepares it for module build and COMPILE_TEST. v2: use guard(), reorganize a bit for clarity. [...]
Applied to powerpc/next.
[1/8] gpio: move ppc4xx gpio driver from arch/powerpc to drivers/gpio
https://git.kernel.org/powerpc/c/66da1ae19672a295507b0c66cd74231e5bf482a9
[2/8] gpio: ppc44x: update all 4xx to 44x
https://git.kernel.org/powerpc/c/f9476e237ab351b840f99aadc865c0fc913b65f9
[3/8] gpio: ppc44x: Use module platform driver helper for GPIO
https://git.kernel.org/powerpc/c/f17b0ef8593d2c9f38197c396146b63e918e46fc
[4/8] gpio: ppc44x: Use platform resource helper for GPIO MMIO
https://git.kernel.org/powerpc/c/8ab2d98f635f77132c9fca4e3983c53729ef52cf
[5/8] gpio: ppc44x: Convert GPIO to generic MMIO
https://git.kernel.org/powerpc/c/714d445a1c8eeefc3167a0e1a6dc766cbc162e40
[6/8] gpio: ppc44x: drop PPC-specific IO helpers
https://git.kernel.org/powerpc/c/595f5f25a96adb4ffec89e973756161c30753276
[7/8] gpio: ppc44x: fix undefined behavior in GPIO_MASK2 macro
https://git.kernel.org/powerpc/c/9c4d539d112fb32355a403513023f08bd17360bc
[8/8] gpio: ppc44x: use dev_name() for chip label
https://git.kernel.org/powerpc/c/98a39710fc8d9c70fcf9bacbb0cc802b0c1a0bbe
cheers