Hello,
Changes in v8:
https://lore.kernel.org/linux-pci/20260508043543.217179-1-kwilczynski@kernel.org/ (local)
- Renamed the generic resource attributes from dev_resourceN_{io,uc,wc}_attr
to pci_dev_resourceN_{io,uc,wc}_attr, for consistency, and cleaned up
resource macros definitions.
- Changed resource macros argument order to fix checkpatch.pl
complaint.
- Added two new macros, pci_legacy_resource_io_attr() and
pci_legacy_resource_mem_attr(), used for the legacy I/O and memory
conversion instead of open-coding each struct bin_attribute. No
functional changes intended.
I will send a follow-up patch with the above changed, mainly to
clean the code up, as v8 didn't made it in time before the merge
window closed. There were no functional changes.
Thank you!
Krzysztof