Thread (31 messages) 31 messages, 10 authors, 16h ago

Re: [PATCH v16 01/18] seccomp: Convert __secure_computing() to return boolean

From: Thomas Gleixner <tglx@kernel.org>
Date: 2026-07-03 20:52:46
Also in: linux-alpha, linux-m68k, linux-mips, linux-mm, linux-riscv, linux-s390, linux-sh, linux-um, lkml, loongarch

On Fri, Jul 03 2026 at 13:59, Kevin Brodsky wrote:
On 03/07/2026 12:27, Michal Suchánek wrote:
quoted
quoted
If we're changing the return type, it might be worth renaming the
function something like:

	seccomp_permits_syscall()
Then not only it is clear which way the boolean value should be
interpreted, it also pervents the accidental inversion of existing
calls. Overall great.
Totally agreed, if we have the opportunity to rename a completely
undescriptive function name like "secure_computing" we should take it.
Absolutely no objections from my side on that.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help