Thread (13 messages) 13 messages, 4 authors, 4h ago

Re: [PATCH v5 0/8] Generic IRQ entry/exit support for powerpc

From: Madhavan Srinivasan <maddy@linux.ibm.com>
Date: 2026-06-19 22:02:16
Also in: lkml

On Mon, 27 Apr 2026 17:57:34 +0530, Mukesh Kumar Chaurasiya (IBM) wrote:
Adding support for the generic irq entry/exit handling for PowerPC. The
goal is to bring PowerPC in line with other architectures that already
use the common irq entry infrastructure, reducing duplicated code and
making it easier to share future changes in entry/exit paths.

This is slightly tested of ppc64le and ppc32.

[...]
Applied to powerpc/next.

[1/8] powerpc: rename arch_irq_disabled_regs
      https://git.kernel.org/powerpc/c/baa590018fbfc3e7384b604c7a7951eecf10a523
[2/8] powerpc: Prepare to build with generic entry/exit framework
      https://git.kernel.org/powerpc/c/dec63ea6fafffb91811381d9a4686d4bc39f01ae
[3/8] powerpc: introduce arch_enter_from_user_mode
      https://git.kernel.org/powerpc/c/09a9d3a8499db606563eb5e75a993419f4d1901e
[4/8] powerpc: Introduce syscall exit arch functions
      https://git.kernel.org/powerpc/c/02565a782c1ee7e8ada38ad24a698e01d6ea9ff8
[5/8] powerpc: add exit_flags field in pt_regs
      https://git.kernel.org/powerpc/c/d7a6797e0bc1ee7bddb8a298f2d1acddb300efb3
[6/8] powerpc: Prepare for IRQ entry exit
      https://git.kernel.org/powerpc/c/893082ac769ba92a1338e7552d97de769f352a3e
[7/8] powerpc: Enable GENERIC_ENTRY feature
      https://git.kernel.org/powerpc/c/bee25f97ad24641df55cb3887eb5bfcb2b9d8fbc
[8/8] powerpc: Remove unused functions
      https://git.kernel.org/powerpc/c/6ed60999d33d49251b42976a5511f1bb089797ed

cheers
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help